File: snmp-mode.el.html

INTRODUCTION
------------
This package provides a major mode for editing SNMP MIBs.

SNMP mode also uses tempo, a textual boilerplate insertion package distributed with Emacs, to add in boilerplate SNMP MIB structures. See tempo.el for more details about tempo.

If you want to change or add new tempo templates, use the tempo tag list snmp-tempo-tags (or snmpv2-tempo-tags): this list is automatically installed when snmp-mode (or snmpv2-mode) is entered.

The SNMPv2 mode in this version has been enhanced thanks to popular demand.

I'm very interested in new tempo macros for both v1 and v2, and any other suggestions for enhancements (different syntax table items, new keybindings, etc.)

USAGE
-----
Mostly, use it as you would any other mode. There's a very simplistic auto-indent feature; hopefully it'll help more than get in your way. For the most part it tries to indent to the same level as the previous line. It will try to recognize some very simple tokens on the previous line that tell it to use extra indent or outdent.

Templates
---------
To use the Tempo templates, type the Tempo tag (or a unique prefix) and use C-c C-i (C-c TAB) to complete it; if you don't have tempo-interactive set to nil it will ask you to fill in values. Fields with predefined values (SYNTAX, STATUS, etc.) will do completing-reads on a list of valid values; use the normal SPC or TAB to complete.

Currently the following templates are available:

 objectType -- Defines an OBJECT-TYPE macro.

 tableType -- Defines both a Table and Entry OBJECT-TYPE, and a
               SEQUENCE for the ASN.1 Entry definition.

Once the template is done, you can use C-cC-f and C-cC-b to move back and forth between the Tempo sequence points to fill in the rest of the information.

Defined variables (28)

snmp-common-mode-hookHook(s) evaluated when a buffer enters either SNMP or SNMPv2 mode.
snmp-completion-ignore-caseNon-nil means that case differences are ignored during completion.
snmp-font-lock-keywordsDefault SNMP MIB mode expression highlighting.
snmp-font-lock-keywords-1Basic SNMP MIB mode expression highlighting.
snmp-font-lock-keywords-2Medium SNMP MIB mode expression highlighting.
snmp-font-lock-keywords-3Gaudy SNMP MIB mode expression highlighting.
snmp-indent-levelIndentation level for SNMP MIBs.
snmp-mode-abbrev-tableAbbrev table in use in SNMP mode.
snmp-mode-access-listPredefined values for ACCESS clauses.
snmp-mode-hookHook(s) evaluated when a buffer enters SNMP mode.
snmp-mode-mapKeymap used in SNMP mode.
snmp-mode-status-listPredefined values for STATUS clauses.
snmp-mode-syntax-listPredefined types for SYNTAX clauses.
snmp-mode-syntax-tableSyntax table used for buffers in SNMP mode.
snmp-rfc1155-accessACCESS values from RFC 1155 v1 SMI.
snmp-rfc1155-typesTypes from RFC 1155 v1 SMI.
snmp-rfc1212-statusSTATUS values from RFC 1212 v1 SMI.
snmp-rfc1213-typesTypes from RFC 1213 MIB-II.
snmp-rfc1902-accessACCESS values from RFC 1155 v1 SMI.
snmp-rfc1902-statusSTATUS values from RFC 1902 v2 SMI.
snmp-rfc1902-typesTypes from RFC 1902 v2 SMI.
snmp-rfc1903-typesTypes from RFC 1903 Textual Conventions.
snmp-special-indentIf non-nil, use a simple heuristic to try to guess the right indentation.
snmp-tab-always-indentNon-nil means TAB should always reindent the current line.
snmp-tempo-tagsTempo tags for SNMP mode.
snmpv2-mode-abbrev-tableAbbrev table in use in SNMPv2 mode.
snmpv2-mode-hookHook(s) evaluated when a buffer enters SNMPv2 mode.
snmpv2-tempo-tagsTempo tags for SNMPv2 mode.

Defined functions (6)

snmp-calculate-indent()
snmp-common-mode(NAME MODE ABBREV FONT-KEYWORDS IMENU-INDEX MODE-TEMPO-TAGS)
snmp-completing-read(PROMPT TABLE &optional PRED REQUIRE INIT HIST)
snmp-indent-line()
snmp-mode()
snmpv2-mode()

Defined faces (0)